Python: 为指定Python版本安装pip

python Logo
image-3442

如果还没有安装pip,先尝试从标准库中对其进行引导:

1
$ python3.6 -m ensurepip --default-pip

如果仍然不允许,可以继续:

下载: get-pip.py

运行

1
 sudo python3.6 get-pip.py

现在,就可以使用pip3为python3.6安装软件包。例如:

1
$ sudo pip3 install requests  # install requests for python3.6

或者,只要已安装相应的pip,就可以将pip用于特定的Python版本,如下所示:

1
$ python3.6 -m pip install requests

发表评论

您的电子邮箱地址不会被公开。

*

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据